Finwise slow response

Incident Report for Finwise Status

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 13:15 SAST

Identified

We are aware that users are currently experiencing slow response on Finwise. Our IT team is attending to this with priority.
Posted Jun 26, 2025 - 12:59 SAST
This incident affected: Finwise Web.