Drex and FNB integration unavailable

Incident Report for Finwise Status

Resolved

This incident has been resolved.
Posted Oct 08, 2025 - 15:32 SAST

Update

The Switch Web API is still offline, and their IT team is working on a fix.
All Finwise communication will continue to be delivered via email until the issue has been resolved.
Posted Oct 07, 2025 - 08:09 SAST

Identified

The switch Web API is currently offline due to an unexpected issue.
Their technical team is actively investigating the root cause and working diligently to restore full functionality as quickly as possible.

During this time all 17.1's sent from Finwise will be delivered to the respective Creditors via email.
Posted Oct 06, 2025 - 11:02 SAST
This incident affected: Finwise Web.