Finwise slow response

Incident Report for Finwise Status

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 14:28 SAST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2026 - 07:31 SAST

Investigating

We are aware that some users are experiencing slower than normal response on Finwise.
Our IT team is investigating this, although it appears to be related to a general internet connectivity issue, affecting various network providers in South Africa. Our team is doing their best to find an optimal solution.
Posted Jul 14, 2026 - 11:12 SAST
This incident affected: Finwise Web.